THROUGH THE LOOKING GLASS | A PRO PHOTO & VIDEO BLOG

And Now, a Word on New Camera Compatibility

Posted in News by Nathan Lee Bush on July 12, 2012

Photographers, Assistants and Studios renting with ARC should be aware that, as with all new camera releases, the new Canon EOS 5D Mark III and 1DX, as well as the Nikon D4 and D800, bring with them compatibility issues, some of which are beyond our control.

The fact is, the files that come from these new cameras may be incompatible and cause issues with different types of imaging & capture software (depending on versions), such as Capture One, Photoshop and Lightroom. Always check the software websites regularly for the latest compatibility and incompatibility with camera systems and file formats.

The following are some known issues to be aware of and best practices when preparing for a shoot:

  • To tether the 5Dmk3 or D1X using Canon Utility software (you must be running Snow Leopard OSX 10.6.) Or If running Lion OSX 10.7, users must download the Canon Utility update from Canon’s website. For the latest copy of the Utility Discs from Canon, call us and we’ll provide it to you or contact Canon directly.
  • To either tether or read RAW files from the Canon EOS 1DX, you must use the Canon Software v. 25.1.2 only.
  • At this time, Phase One’s C1 Pro software v. 6.4.2 is the latest version available. It is totally incompatible for tethering but does have RAW file support form CF Cards with the following new camera systems: 5D Mark III, D4, D800 (but at the moment the EOS 1DX will not tether or read the RAW file format in C1 Pro any version).
  • There is also a converter application called Adobe DNG Converter, which converts RAW files into .DNG files. For example, a Canon RAW file 10025.CR2 will look like this when converted through the app: 10025.DNG. This application doesn’t change the structure of the RAW file, it just allows programs like Photoshop to open and convert the RAW file into a JPG or TIFF filetype. This free application is available at adobe.com. DNG Converter 7.1 is needed to open the aforementioned cameras.
  • Photoshop 5.6 and up requires upgrade RAW file converter to the latest version.
  • Read release notes in Capture 1 Pro. Always check the latest version of software compatibility release notes. RAW compatibility does not necessarily imply tethering support.

If you have any questions about software compatibility or how to reinstall an application, please don’t hesitate to ask one of our staff in the Digital Department.

Advertisements
Tagged with:

One Response

Subscribe to comments with RSS.

  1. Gerard said, on July 12, 2012 at 9:06 pm

    Holy crap!


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: